Тема Joomla 1.5 та локалі (utf, 1251)

Форуми по лінійці Joomla 1.5.x.
Andrew
Користувач
Користувач
Повідомлень: 43
З нами з: 30 березня 2007, 10:15

Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Andrew » 21 лютого 2008, 20:01

>:(

тиждень мурдуюся (вивчаю) дж 1.5.1...ніяк неможу найти відповіді на питання:

1.де виставляється локаль ????? (розумію що нема ткого..)

2.все так розумію в UTF, українізівані чи русифіковані компони такі як комуніті білдер чи фаєрборд...і інші йдуть в 1251 - як позбавитись ієрогліфів ??????
переробив мовні.пшп на ютф так в футері лізе гидота...то в тітлі...
переробляти усі мовні та інші файли в UTF - це ж брєд!!! в пшпмайадмін не вдалося повязати ці речі..

3. як зробити щоб джума автоматом по-людськи працювала з 1251...чи з якою там холєрою...

4. вихід ?

5. неподобається щось мені це... >:(

Аватар користувача
Dutch
Адміністратор
Адміністратор
Повідомлень: 1166
З нами з: 28 жовтня 2006, 18:49
Звідки: Київ
Дякував (ла): 2 рази
Подякували: 12 рази
Контактна інформація:

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Dutch » 23 лютого 2008, 01:49

Andrew писав:1.де виставляється локаль ????? (розумію що нема ткого..)
В XML мовного файлу! Але там перелічені усі можливі локалі. Єдине, що пріоритет у першої локалі!!!!
Andrew писав:
2.все так розумію в UTF, українізівані чи русифіковані компони такі як комуніті білдер чи фаєрборд...і інші йдуть в 1251 - як позбавитись ієрогліфів ??????
переробив мовні.пшп на ютф так в футері лізе гидота...то в тітлі...
переробляти усі мовні та інші файли в UTF - це ж брєд!!! в пшпмайадмін не вдалося повязати ці речі..

Ти впевнений, що розширення працюють в рідному режимі 1.5.х?

Вихід є один: перекодувати мовні!!! файли в ЮТФ-8 без BOM!!!
Andrew писав:3. як зробити щоб джума автоматом по-людськи працювала з 1251...чи з якою там холєрою...

А зміст, якщо ютф-8 загально прийняте кодування?

Коректно перекодуй у ютф-8
Mishanchik
Користувач
Користувач
Повідомлень: 3
З нами з: 21 березня 2008, 23:22

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Mishanchik » 21 березня 2008, 23:44

Допоможіть такий трабл (в мене дж 1.5.1 і денвер):
Вставив компонент який на англійській мові. Я його трохи перевів і побачив замість тексту -  "??????".
Змінюю кодування в браузері на Windows-1251 і переклад стає нормально а все(все повністю) інше псується. в бд скрізь встановив utf-8 і всерівно не допомагає.

Допоможіть хто небуть. Дякую.   
Аватар користувача
Dutch
Адміністратор
Адміністратор
Повідомлень: 1166
З нами з: 28 жовтня 2006, 18:49
Звідки: Київ
Дякував (ла): 2 рази
Подякували: 12 рази
Контактна інформація:

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Dutch » 22 березня 2008, 00:56

перекодуй файл зі своїм перекладом в кодування utf-8
Mishanchik
Користувач
Користувач
Повідомлень: 3
З нами з: 21 березня 2008, 23:22

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Mishanchik » 22 березня 2008, 18:08

А як це зробити? Бо в SQL змінив і неробить...

Аватар користувача
Dutch
Адміністратор
Адміністратор
Повідомлень: 1166
З нами з: 28 жовтня 2006, 18:49
Звідки: Київ
Дякував (ла): 2 рази
Подякували: 12 рази
Контактна інформація:

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Dutch » 22 березня 2008, 19:19

Відкрий файл або в Notepade++, або в AkelPad та перекодуй його у ютф-8.
Mishanchik
Користувач
Користувач
Повідомлень: 3
З нами з: 21 березня 2008, 23:22

Re: Тема Joomla 1.5 та локалі (utf, 1251)

Повідомлення Mishanchik » 22 березня 2008, 22:02

Дуже велике дякую! Працює!!!!  >|

  • Similar Topics
    Відповіді
    Перегляди
    Останнє повідомлення

Повернутись до “Joomla! 1.5”

Хто зараз онлайн

Зараз переглядають цей форум: 4 і 0 гостей