Не ставятся компоненты

Форуми по лінійці Joomla 1.0.x.
Nick_mad
Користувач
Користувач
Повідомлень: 9
З нами з: 24 січня 2007, 17:10

Не ставятся компоненты

Повідомлення Nick_mad » 01 березня 2007, 15:10

Здравствуйте.

Не долго я радовался. Еле уломал админа перекомпилить РНР (ver 4.2.0) споддержкой gd, zlib, bz2, а то устал постоянно возится с компонентами да модулями и роботами в гостевой.
Так вот после успешной перекомпиляции РНР пытаюсь установить компонент, а оно мне выдает:

Неисправимая ошибка "PCLZIP_ERR_BAD_FORMAT (-10)"
Установочный файл не найден:

переписываю на хост в папку /administrator/components/com_installer/component выдает:

Установочный файл не найден:
/usr/home/****/www/administrator/components/com_installer/component

Как Вы думаете что бы это могло значить? И как это разрулить?

mr.Z
Користувач
Користувач
Повідомлень: 47
З нами з: 17 листопада 2006, 17:56

Re: Не ставятся компоненты

Повідомлення mr.Z » 01 березня 2007, 15:31

Власне зроби так, як тобі порадив userxp, або прочитай цю статтю.
Востаннє редагувалось 01 березня 2007, 16:05 користувачем mr.Z, всього редагувалось 1 раз.
Nick_mad
Користувач
Користувач
Повідомлень: 9
З нами з: 24 січня 2007, 17:10

Re: Не ставятся компоненты

Повідомлення Nick_mad » 01 березня 2007, 16:03

AkoBook342_DGM-design_v.03  ;D

а ты и на joomlaforum  смотришь :)
Востаннє редагувалось 01 березня 2007, 16:11 користувачем Nick_mad, всього редагувалось 1 раз.
Аватар користувача
Dutch
Адміністратор
Адміністратор
Повідомлень: 1166
З нами з: 28 жовтня 2006, 18:49
Звідки: Київ
Дякував (ла): 2 рази
Подякували: 12 рази
Контактна інформація:

Re: Не ставятся компоненты

Повідомлення Dutch » 01 березня 2007, 18:38

Nick_mad чузззз!!  ;)
Nick_mad
Користувач
Користувач
Повідомлень: 9
З нами з: 24 січня 2007, 17:10

Re: Не ставятся компоненты

Повідомлення Nick_mad » 02 березня 2007, 09:08

to mr.Z
Спасибо, сделал и так и так.
от ошибки "Неисправимая ошибка "PCLZIP_ERR_BAD_FORMAT (-10)"" избавился но все равно как то туго с инсталяцией, все равно приходится устанавливать на локале а потом файлы и таблицы БД переписывать на хостинг.
Я тему проблемы инсталяции не раз подымал. Как то странно себя Joomla ведет на хостинге. На локале все гуд и на сделаном мною серваке для тестов тоже ок. А вот на другом серваке. Возможно это связано с устаревшими версиями апача, мускула и РНР.

P.S. Видишь на jomlaforum даже не церемонились, сразу тему в мусор. Та и правильно, завтыкал, там аж 3 темы таких было поднято с ссылкой на вышеуказаную статтю.
А на этом же форуме такая тема не подымалась :)

mr.Z
Користувач
Користувач
Повідомлень: 47
З нами з: 17 листопада 2006, 17:56

Re: Не ставятся компоненты

Повідомлення mr.Z » 02 березня 2007, 17:26

З приводу тугої інсталяції - то це явно проблема сервера. Якщо є можливість, то треба оновити PHP хоча б до версії 4.4.x, а решту налаштувань винести тобі в .htaccess.
Аватар користувача
Dutch
Адміністратор
Адміністратор
Повідомлень: 1166
З нами з: 28 жовтня 2006, 18:49
Звідки: Київ
Дякував (ла): 2 рази
Подякували: 12 рази
Контактна інформація:

Re: Не ставятся компоненты

Повідомлення Dutch » 02 березня 2007, 17:40

Глянь, що у тебе із Save Mode

Повернутись до “Joomla! 1.0”

Хто зараз онлайн

Зараз переглядають цей форум: 2 і 0 гостей