Форум Joomla! Україна

Повна версія: Допоможіть: Joomla! 1.0.11 .1 - PHP5.3.3-7+squeeze1
Ви переглядаєте спрощену версію. Переглянути повну версію з віповідним форматуванням.
Доброго всім часу доби!
Звертаюся до усіх форумчан за допомогою: я маю два сайти в Joomla! 1.0.11 .1 і практично з 2007 року я її не обновлював. Нещодавно провайдер перейшов на PHP5.3.3-7+squeeze1 і як я розумію верісія Joomla! 1.0.11 .1 не є сумісною з даним PHP, бо у мене відразу сайти переповнилися помилками. Деякі вдалося вирішити, а інші ні.
Отож, спершу на головній сторінці не відображало інформіції, видаючи ось цю помилку: «Warning: Parameter 2 to frontpage () expected to be a reference, value given in ...includesCacheLiteFunction.php on line 100». Скориставшись порадами на різних форумах зробив наступне: в "includesCacheLiteFunction.php on line 100" замінив "$arguments = func_get_args ();" на
$arguments = func_get_args ();
$numargs = func_num_args ();
for ($i=1; $i < $numargs; $i++){
$arguments[$i] = &$arguments[$i];
}

а також в /includes/vcard.class.php :
лінія 38:
додав ось це:
if(!function_exists('quoted_printable_encode'))
{
/* line 38 to 77 */
}

Помилка виправлена. Проте коли заходжу в панель адміністрування, то практично не можу нічого робити, оскільки при спробі публікувати новий матеріал в редакторі пропали кнопки "зберегти" та ін...
Коли намагаюся відкрити будь-який модуль, то видає цілий ряд помилок, ось одна із них Warning: Parameter 1 to DOMIT_Lite_Parser:ConfusedtartElement() expected to be a reference, value given in /home/mhd-01/www/htdocs/ucra/includes/domit/xml_saxy_shared.php on line 260. В більшості усі помилки повязані із xml_saxy_shared.php.
Порадьте, що можна зробити, щоб вирішити дану проблему? Доречі, в італомовній версії в Joomla! 1.0.11 .1 інший мій сайт схожих проблем немає, хоча знаходиться на тому ж сервері...
Чи є можливість замінити якийсь код в xml_saxy_shared.php ?
Чи потрібно обновлювати Joomla! 1.0.11 .1, якщо так, то чи можна зразу переходити на останню версію і як це робити? Що трапиться із модулями, які виготовлені для Joomla! 1.0.11 .1?
Наперед щиро усім вдячний!
Джумла 1.0 не підтримує PHP 5.3.

Варіан вирішення проблеми:
1. Попросити хостера надати підтримку нижче 5.3 (хостер повинен надавати такі послуги)
2. Оновити сайт хоча б до версії джумла 1.5