Форум Joomla! Україна

Повна версія: глюк при створенні статті(відображення фону редактора)
Ви переглядаєте спрощену версію. Переглянути повну версію з віповідним форматуванням.
коли створюю статтю, то фон (там де текст статті повинен бути) в адмінці чомусь бекграундом сайту вибиває
версія Joomla! 1.0.12 Lavra Edition 2007
Який редактор використовується?
pluhpluh Написав:коли створюю статтю, то фон (там де текст статті повинен бути) в адмінці чомусь бекграундом сайту вибиває
версія Joomla! 1.0.12 Lavra Edition 2007

є таке. там здається треба css редактора правити
Ну, у разі якщо це JCE Editor, то потрібно в папці css активної теми створити відповідний файл зі стилем редактора, а в адмінці навпроти строки "custom CSS Classes" додати назву цього файлу. Опцію ж "Template CSS classes" деактивуємо.
Shaman Написав:Який редактор використовується?

рідний  TinyMCE

поставила JCE
2Shaman - дякую, допомогло Smile
і з*явилося наступне))бекграунд(лише в тому місці) де продовження статті з*їзжає вправо десь на 10-15px -а цього в ксс-і точно немає) ну і це з*явилось після того як фон нормалізувала.зробила все як тут написано http://joomlaportal.ru/content/view/399/53/ .пробувала шаблон знести/поставити, редактор вкл/викл - нічого не змінюється.ось
а глянути можна?
спробуй забрати всі overflow:hidden;
та в id  #content постав width:100%;
те ж саме.майже..більш логічно здвинулось тільки))не одним боком а повністю))))))
pluhpluh Написав:бекграунд(лише в тому місці) де продовження статті з*їзжає вправо десь на 10-15px -а цього в ксс-і точно немає)

З практики знаю, що проблеми з оформленням виникають тоді, коли якраз чогось в css  не вистачає.
Поексперементуй з файлом стилю редактора - наприклад скопіюй зміст css теми сайту (оскільки при тодішньому оформленні проблем не було) , та зміни колір фону на #FFF чи який потрібно і так далі.
те ж саме :-[

Shaman Написав:З практики знаю, що проблеми з оформленням виникають тоді, коли якраз чогось в css  не вистачає.
Поексперементуй з файлом стилю редактора - наприклад скопіюй зміст css теми сайту (оскільки при тодішньому оформленні проблем не було) , та зміни колір фону на #FFF чи який потрібно і так далі.

я не зовсім розумію, точніше зовсім не розумію чому при перестановці шаблона(без змін в тому вигляді якій він був спочатку) все залишається так само.і ще інсталюються криво(але це з самого початку так було).тобто інсталюється все ок, а таке враження що стилі взагалі не бачить-видно тільки колір бекграунда та текст зі структурою меню але без позицій модулів, якщо на дівах.тб ксс не бачить.ну а коли залити то все ок

хто у нас тут найрозумніший?)))Dutch, може є якісь думки?
pluhpluh Написав:таке враження що стилі взагалі не бачить-видно тільки колір бекграунда та текст зі структурою меню але без позицій модулів, якщо на дівах.тб ксс не бачить.ну а коли залити то все ок

щоб гарно бачити структуру html і css-стилі які використовуються смпробуй плагін до ФФ 2.х https://addons.mozilla.org/ru/firefox/se...ug&cat=all
Цитата:щоб гарно бачити структуру html і css-стилі які використовуються смпробуй плагін до ФФ 2.х https://addons.mozilla.org/ru/firefox/se...ug&cat=all
Піпєц - щойно те само кинув в приват Smile
ps: мова йдеться про фронтенд а не редактор адмінки (я це зрозумів тільки щойно).
Цитата:хто у нас тут найрозумніший?)))Dutch, може є якісь думки?
2pluhpluh: Щоб краще було видно проблему іншим, думаю варто викласти скрін або дати на неї лінк
Smile
я саме цим і займаюся)))
знаєте що то було?))я в шоці Big Grin ті статті що були зі зміщенним бекграундом текст до них копіювала з WebCopier Pro.ксс і так переписувала і сяк-результату-0, тільки під вечір коли вже це набридло вирішила знести редактор та заново поставити,поставила а там теж саме))потім дивлюсь що одна стаття норм відображ(вручну була додана)..спробувала з браузера текст скопіювати і все норм))


2GOodm@n,Shaman
хлопці, дякую за допомогу  Wink
>|